Чтение данных из EXCEL

Ответить

Код подтверждения
Введите код в точности так, как вы его видите. Регистр символов не имеет значения.
Смайлики
:) :( ;) :D ;;) :ymhug: :-\ :x :ymblushing: :p :-* =(( :-o X( :ymsmug: B-) :-s #:-s :ymdevil: :(( :)) :| /:) =)) O:-) :-B =; i-) 8-| L-) :ymsick: :-$ [-( :o) 8-} :ymparty: (-| =p~ :-? #-o :ymapplause: :-ss @-) :^o :-w :ymsigh: :ymtongue: :ymcowboy: :@) 3:-O :(|) @};- %%- **== (~~) ~o) *-:) 8-x =:) :ymalien: :-l :ympray: $-) :- b-( :ympeace: [-x \:D/ :ymbringiton: ;)) :ymhiro: :ymbilly: o-+ (%) :-@ ^:)^ :-j (*) :)] :-c ~x( :-h :-t :ymdaydream: :-?? %-( :o3 x_x :!! \m/ :-q :-bd ^#(^ :-! :ar!
Еще смайлики…
BBCode ВЫКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ
Обзор темы
   

Развернуть Обзор темы: Чтение данных из EXCEL

Чтение данных из EXCEL

Сообщение admin » 27 мар 2020, 09:51

Функция возвращает таблицу значений с данными и структурой тождественной файлу источнику.

Код: выделить все
#Область EXCEL

// Функция - Read excel
//
// Параметры:
//  Лист       - Число - Какой лист читать
//  СтрокаСтарта - Число - С какой строки начинать чтение
//
// Возвращаемое значение:
//   - Таблица значений, тождественной содержимому исходного файла
//
Функция ReadExcel(Лист=1, СтрокаСтарта = 2) Экспорт // создаем ТЗ на основе файла
   Попытка
      E = Новый COMОбъект("Excel.Application");
   Исключение
      Предупреждение("Excel на компьютере не установлен!");
      Возврат Неопределено;
   КонецПопытки;
   E.Workbooks.Open(Сокрлп(ПутьКФайлу));
   Строк=E.Sheets(Лист).Cells.SpecialCells(11).Row; // строка последней ячейки
   Столбцов=E.Sheets(Лист).Cells.SpecialCells(11).Column; // столбец последней ячейки
   фТЗ = Новый ТаблицаЗначений;
   Для А=1 По Столбцов Цикл
      фТЗ.Колонки.Добавить();
   КонецЦикла;
   Для Стр=СтрокаСтарта По Строк Цикл 
      Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));     
      строка = фТЗ.Добавить();     
      Для Столб=1 По Столбцов Цикл   
         строка[Столб-1] = СокрЛП(E.Sheets(Лист).Cells(Стр,Столб).Value);
      КонецЦикла;
   КонецЦикла;
   E.Workbooks.Close();
   Возврат фТЗ;   
КонецФункции

#КонецОбласти

Вернуться наверх


Яндекс.Метрика
cron