Чтение данных из EXCEL

Аватар пользователя
Администратор
Сообщений: 152
Зарегистрирован: 27 фев 2011, 17:40
Откуда: откуда и все :)
СообщениеДобавлено: 27 мар 2020, 09:51
Функция возвращает таблицу значений с данными и структурой тождественной файлу источнику.

Код: выделить все
#Область EXCEL

// Функция - Read excel
//
// Параметры:
//  Лист       - Число - Какой лист читать
//  СтрокаСтарта - Число - С какой строки начинать чтение
//
// Возвращаемое значение:
//   - Таблица значений, тождественной содержимому исходного файла
//
Функция ReadExcel(Лист=1, СтрокаСтарта = 2) Экспорт // создаем ТЗ на основе файла
   Попытка
      E = Новый COMОбъект("Excel.Application");
   Исключение
      Предупреждение("Excel на компьютере не установлен!");
      Возврат Неопределено;
   КонецПопытки;
   E.Workbooks.Open(Сокрлп(ПутьКФайлу));
   Строк=E.Sheets(Лист).Cells.SpecialCells(11).Row; // строка последней ячейки
   Столбцов=E.Sheets(Лист).Cells.SpecialCells(11).Column; // столбец последней ячейки
   фТЗ = Новый ТаблицаЗначений;
   Для А=1 По Столбцов Цикл
      фТЗ.Колонки.Добавить();
   КонецЦикла;
   Для Стр=СтрокаСтарта По Строк Цикл 
      Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(Строк));     
      строка = фТЗ.Добавить();     
      Для Столб=1 По Столбцов Цикл   
         строка[Столб-1] = СокрЛП(E.Sheets(Лист).Cells(Стр,Столб).Value);
      КонецЦикла;
   КонецЦикла;
   E.Workbooks.Close();
   Возврат фТЗ;   
КонецФункции

#КонецОбласти
Проблема, это задача в решении которой никто не заинтересован.
СВС
Цитата

Вернуться в Для программиста

Кто сейчас на форуме

Сейчас этот форум просматривают: yandex и гости: 2


Яндекс.Метрика
cron