ADODB Connection в 1С

За долгую практику программирования в среде 1С, накапливается немало опыта и как следствие появляются на свет всякие вкусности и полезняшки, которые когда то облегчили жизнь, а теперь, возможно, пригодятся Вам. В этой ветке форума разрешены комментарии для гостей с предварительной модерацией.
Аватар пользователя
Администратор
Сообщений: 149
Зарегистрирован: 27 фев 2011, 17:40
Откуда: откуда и все :)
СообщениеДобавлено: 16 янв 2012, 10:21
Пример реализации подключения и работы.
Код: выделить все
Процедура Сформировать()
   Path="c:\"; //Путь к папке с файлами DBF
 
  //Стираем файл, если он уже существует
  Если фс.СуществуетФайл("c:\persons.dbf")=1 Тогда
      фс.УдалитьФайл("c:\persons.dbf");
  КонецЕсли;   
 
  //******* ПРИМЕР ЗАПИСИ DBF *******//

  //Открываем соединение
  DBConn = CreateObject("ADODB.Connection");
  DBConn.Open("Provider=Microsoft.Jet.OLEDB.4.0;" +
                   "Data Source=" + Path + ";" +
                   "Extended Properties=""DBASE IV;"";");           

  //Создаем новый DBF и задаем его колонки
  DBConn.Execute("Create Table Persons (Name char(50), City char(50), Phone char(20), Zip decimal(5))");

  //Пишем строки в наш DBF
  DBConn.Execute("Insert into Persons Values('Иванов И.И.', 'Москва','123-45-67','14589')");
  DBConn.Execute("Insert into Persons Values('Поляков С.Л.', 'Москва','333-44-55','38215')");
  DBConn.Execute("Insert into Persons Values('Сидоров С.С.', 'Москва','222-33-44','54323')");
 
 
  //******* ПРИМЕР ЧТЕНИЯ DBF *******//
 

  //Делаем выборку
  Persons = DBConn.Execute("Select * from [Persons#DBF]");


  Пока Persons.EOF=0 Цикл //Цикл по записям DBF
   
    Имя=    Persons.Fields("Name").value;
    Город=  Persons.Fields("City").value;
    Телефон=Persons.Fields("Phone").value;
    Zip=    Persons.Fields("Zip").value;
   
    Сообщить("Имя="+Имя+" Город="+Город+" Телефон="+Телефон+" Zip="+Zip);
   
    Persons.MoveNext(); //Переходим к след. записи DBF
  КонецЦикла;

  DBConn.Close(); //Закрываем соединение
КонецПроцедуры


Приведенный пример работы с данными можно использовать не только в "семерке", но и в более младших "моделях" платформы.
Проблема, это задача в решении которой никто не заинтересован.
СВС
Цитата

Вернуться в 1С

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Яндекс.Метрика
cron