Использование СледующийПоЗначениюПоля("ИмяПоля")

Аватар пользователя
Администратор
Сообщений: 145
Зарегистрирован: 27 фев 2011, 17:40
Откуда: откуда и все :)
СообщениеДобавлено: 19 дек 2017, 11:28
Допустим, тебе не нужны итоги (суммы) и все группировки ты уже реализовал в запросе который возвращает полностью агрегированный результат.
Например такой вариант у меня получился, когда собирал статистику использования МЦ в разрезе характеристик, свойств и дат.
В принципе любая статистическая информация подходит под этот вариант.
Обход группировок стандартными способами в этом случае не всегда корректно работает, т.к. нет суммируемых полей.
Выход из положения подсказал метод из заголовка - СледующийПоЗначениюПоля("ПолеГруппировки").

Как это работает:
У тебя есть таблица-результат:
Фамилия1 Имя1 Отчество1
Фамилия1 Имя1 Отчество2
Фамилия1 Имя2 Отчество3
Фамилия1 Имя2 Отчество4

Какие тут могут быть итоги? - Никаких!

А теперь поехали:
Код: выделить все
Пока Выборка.СледующийПоЗначениюПоля("Фамилия") Цикл
    // Чего то делаешь для фамилии
    Пока Выборка.СледующийПоЗначениюПоля("Имя") Цикл
        // Чего то делаешь для имени
        Пока Выборка.СледующийПоЗначениюПоля("Отчество") Цикл
           // Чего то делаешь для отчества
        КонецЦикла;
    КонецЦикла;
КонецЦикла;


Собственно почитать мат часть можно по F1, а как использовать написал выше. :ymhug:
Проблема, это задача в решении которой никто не заинтересован.
СВС
Цитата

Вернуться в Для программиста

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0


Яндекс.Метрика
cron